[Fedora] ERROR en el chequeo de la transacción vs resolución de dependencias: WTF?

Intentando actualizar Fedora hoy me encuentro con que por el administrador de paquetes fallaba la actualización con un cartel medio extraño. Inmediatamente me voy a una consola, tiro un yum update y me encuentro con este error:

ERROR en el chequeo de la transacción vs resolución de dependencias:
kernel-uname-r = 2.6.40.4-5.fc15.x86_64 is needed by kmod-wl-2.6.40.4-5.fc15.x86_64-5.60.48.36-2.fc15.8.x86_64
kernel-uname-r = 2.6.40.6-0.fc15.x86_64 is needed by kmod-wl-2.6.40.6-0.fc15.x86_64-5.60.48.36-2.fc15.9.x86_64
kernel-uname-r = 2.6.41.1-1.fc15.x86_64 is needed by kmod-wl-2.6.41.1-1.fc15.x86_64-5.100.82.38-1.fc15.2.x86_64
Por favor, informe este error en http://yum.baseurl.org/report

Recuerden que hice un preupgrade (es decir actualicé de Fedora 15 a 16 sin reinstalar), con lo que aparentemente tengo un quilombo importante de paquetes.. Luego de investigar un rato largo y probar un par de comandos pude actualizar haciendo lo siguiente:

  1. Ejecutar yum check
  2. Desinstalar todos los paquetes que lista el comando anterior con yum erase <nombre de paquete o listado de los nombres de los paquetes>
  3. Actualizar felizmente con yum update o con la interfaz gráfica (no probé esta última).
  4. Profit!

Espero que les sirva de ayuda!

Saludos!

Anuncios

2 pensamientos en “[Fedora] ERROR en el chequeo de la transacción vs resolución de dependencias: WTF?

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s